# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\()(?<!eq )'(?!\)|\Z)/''/gm;t' <<< "('hel'lo') eq 'some 'variable he're
"