#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\/\w+\/?|\/\*\/?|\/\*\*\/?)+$"
Local $sString = "positive:" & @CRLF & _
"/foo/bar" & @CRLF & _
"/foo/bar/" & @CRLF & _
"/*" & @CRLF & _
"/foo/*" & @CRLF & _
"/foo/*/bar" & @CRLF & _
"/foo*" & @CRLF & _
"/**" & @CRLF & _
"/foo**" & @CRLF & _
"/foo/**" & @CRLF & _
"/foo/**/bar" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"negative:" & @CRLF & _
"foo" & @CRLF & _
"foo/bar" & @CRLF & _
"//foo" & @CRLF & _
"/foo//bar" & @CRLF & _
"/foo/***/bar" & @CRLF & _
"/***"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")