using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z_$][0-9a-zA-Z_$]*)\s?=\s?new XMLHttpRequest.+?(\1\.((open|send)\(.+?\)))";
string input = @"function sendREq(url) {
var xhr_req=new XMLHttpRequest();
xhr.onreadystatechange = function() {
if (xhr.readyState == XMLHttpRequest.DONE) {
alert(xhr.responseText);
}
}
xhr_req.open('GET', 'http://example.com', true);
xhr_req.send(null);
}
var namedFunc = function(param1, param2) {
// return param1 * param2
}
var req = new XMLHttpRequest()
req.open('POST', 'http://example.com', false);
req.send(null)
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}