# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([a-zA-Z_$][0-9a-zA-Z_$]*)\s?=\s?new XMLHttpRequest.+?(\1\.((open|send)\(.+?\)))"
test_str = ("function sendREq(url) {\n"
" var xhr_req=new XMLHttpRequest();\n"
"xhr.onreadystatechange = function() {\n"
" if (xhr.readyState == XMLHttpRequest.DONE) {\n"
" alert(xhr.responseText);\n"
" }\n"
"}\n"
"xhr_req.open('GET', 'http://example.com', true);\n"
"xhr_req.send(null);\n"
"}\n\n"
"var namedFunc = function(param1, param2) {\n"
" // return param1 * param2\n"
"}\n\n"
"var req = new XMLHttpRequest()\n"
"req.open('POST', 'http://example.com', false);\n"
"req.send(null)\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.