import Foundation
let pattern = #"([a-zA-Z_$][0-9a-zA-Z_$]*)\s?=\s?new XMLHttpRequest.+?(\1\.((open|send)\(.+?\)))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
function sendREq(url) {
var xhr_req=new XMLHttpRequest();
xhr.onreadystatechange = function() {
if (xhr.readyState == XMLHttpRequest.DONE) {
alert(xhr.responseText);
}
}
xhr_req.open('GET', 'http://example.com', true);
xhr_req.send(null);
}
var namedFunc = function(param1, param2) {
// return param1 * param2
}
var req = new XMLHttpRequest()
req.open('POST', 'http://example.com', false);
req.send(null)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)