# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/name="([a-zA-Z])(\w+)/name="\U\1\L\2/g;t' <<< "name=\"Text\""