re = /<\s*(\/?\s*)(b|i|u|br|button|div)(\s?|\s+[\s\S]*?)(\/)?\s*>/i
str = '<b>
</b>
< b >
< /b >
<br>
<br/>
<br /><br />
<br/ >
<br / >
< br / >
<button id="myButton" readonly />button content</button/>
<div class="myClass">div content</div>
<div class="myClass" >div content</ div>
<div class="myClass" />
// NOT CONVERTED
<bb>
A > B
B <= C'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end