#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^moduleFor\('(.*?)'\)$"
Local $sString = "moduleFor('mixin:foo')" & @CRLF & _
"" & @CRLF & _
"// or" & @CRLF & _
"" & @CRLF & _
"moduleFor('route:bar')"
Local $sSubst = "moduleFor('$1', 'unit@$1')"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)