const regex = /(?:^|\s)членс.*(июн|июл|авг|сент|окт|дек|янв|февр|мар|апр|май|мая).*?(\d{4})/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\s)членс.*(июн|июл|авг|сент|окт|дек|янв|февр|мар|апр|май|мая).*?(\\d{4})', 'gi')
const str = `Оплата по счету № 24260 от 25.06.2019г. Членские взносы июль 2019г. ИГК 1619187302962432209016045. Сумма 4000-00 Без налога (НДС)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}