re = /(?:^|\s)членс.*(июн|июл|авг|сент|окт|дек|янв|февр|мар|апр|май|мая).*?(\d{4})/i
str = 'Оплата по счету № 24260 от 25.06.2019г. Членские взносы июль 2019г. ИГК 1619187302962432209016045. Сумма 4000-00 Без налога (НДС)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end