#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?x)\^ ( \( ( (?: [^()]* | (?-2) )* ) \) ) (?!.*\^\()"
Local $sString = "this should be transformed a^(x²) and this b^(-(x²))"
Local $sSubst = "^{$2}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)