using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\^ ( \( ( (?: [^()]* | (?-2) )* ) \) ) (?!.*\^\()";
string substitution = @"^{$2}";
string input = @"this should be transformed a^(x²) and this b^(-(x²))";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}