re = /\^ ( \( ( (?: [^()]* | (?-2) )* ) \) ) (?!.*\^\()/x
str = 'this should be transformed a^(x²) and this b^(-(x²))'
subst = '^{$2}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result