# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\S+\s\d+\\/\d+\\/\d+//gm;t' <<< "Buxtehude /1234 KundenAuftragEinsatzart1 698874/6387/01
KundenAuftragEinsatzart 698874/6387
Musterstadt /1234 KundenAuftragEinsatzart2 698874/6387/01
KundenAuftragEinsatzart3 698874/6387/01
KundenAuftragEinsatzart4 698874/6387/01"