#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\S+\s\d+\/\d+\/\d+"
Local $sString = "Buxtehude /1234 KundenAuftragEinsatzart1 698874/6387/01" & @CRLF & _
"KundenAuftragEinsatzart 698874/6387" & @CRLF & _
"Musterstadt /1234 KundenAuftragEinsatzart2 698874/6387/01" & @CRLF & _
"KundenAuftragEinsatzart3 698874/6387/01" & @CRLF & _
"KundenAuftragEinsatzart4 698874/6387/01"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)