package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\S+\s\d+\/\d+\/\d+`)
var str = `Buxtehude /1234 KundenAuftragEinsatzart1 698874/6387/01
KundenAuftragEinsatzart 698874/6387
Musterstadt /1234 KundenAuftragEinsatzart2 698874/6387/01
KundenAuftragEinsatzart3 698874/6387/01
KundenAuftragEinsatzart4 698874/6387/01`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}