using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\S+\[v=\""(timeSeries)-(\w+)\"",g=\""(\w+)\"",p=\""(\S+)\""\]\S+array\[(\d+)\]\/(\S+)";
string input = @"root/12-825-ReturnAndStatsCompositeAPI[v=""timeSeries-return"",g=""timeSeries"",p=""{""rollingPeriod"":""1Y"",""numberOfPeriods"":""5"",""asOfDate"":""2016-12-31"",""startDate"":""2011-12-31"",""frequency"":""1Y""}""]/data/share_classes/array[1]/returns_series/returns/array[1]/net/cumulative
root/2-825-ReturnAndStatsCompositeAPI[v=""timeSeries-benchmark"",g=""timeSeries"",p=""{""rollingPeriod"":""1Y"",""column"":""column"",""numberOfPeriods"":""5"",""asOfDate"":""2016-12-31"",""startDate"":""2011-12-31"",""frequency"":""1Y""}""]/data/share_classes/array[1]/benchmark_types/benchmark_types_breakdown/array[3]/returns_series/returns/array[1]/gross/annualized
root/2-825-ReturnAndStatsCompositeAPI[v=""timeSeries-benchmark"",g=""timeSeries"",p=""{""rollingPeriod"":""1Y"",""column"":""column"",""numberOfPeriods"":""5"",""asOfDate"":""2016-12-31"",""startDate"":""2011-12-31"",""frequency"":""1Y""}""]/data/share_classes/array[1]/benchmark_types/benchmark_types_breakdown/array[3]/mpt_statistics_series/relative/gross/array[1]/excess_return
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}