using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[A-Za-z0-9+]{4})*(?:[A-Za-z0-9+]{2}==|[A-Za-z0-9+]{3}=|[A-Za-z0-9+]{4})$";
string input = @"TGUgTG9yZW0gSXBzdW0gZXN0IHNpbXBsZW1lbnQgZHUgZmF1eCB0ZXh0ZSBlbXBsb3nDqSBkYW5zIGxhIGNvbXBvc2l0aW9uIGV0IGxhIG1pc2UgZW4gcGFnZSBhdmFudCBpbXByZXNzaW9uLiBMZSBMb3JlbSBJcHN1bSBlc3QgbGUgZmF1eCB0ZXh0ZSBzdGFuZGFyZCBkZSBsJ2ltcHJpbWVyaWUgZGVwdWlzIGxlcyBhbm7DqWVzIDE1MDAsIHF1YW5kIHVuIHBlaW50cmUgYW5vbnltZSBhc3NlbWJsYSBlbnNlbWJsZSBkZXMgbW9yY2VhdXggZGUgdGV4dGUgcG91ciByw6lhbGlzZXIgdW4gbGl2cmUgc3DDqWNpbWVuIGRlIHBvbGljZXMgZGUgdGV4dGUuIElsIG4nYSBwYXMgZmFpdCBxdWUgc3Vydml2cmUgY2lucSBzacOoY2xlcywgbWFpcyBzJ2VzdCBhdXNzaSBhZGFwdMOpIMOgIGxhIGJ1cmVhdXRpcXVlIGluZm9ybWF0aXF1ZSwgc2FucyBxdWUgc29uIGNvbnRlbnUgbidlbiBzb2l0IG1vZGlmacOpLiBJbCBhIMOpdMOpIHBvcHVsYXJpc8OpIGRhbnMgbGVzIGFubsOpZXMgMTk2MCBncsOiY2Ugw6AgbGEgdmVudGUgZGUgZmV1aWxsZXMgTGV0cmFzZXQgY29udGVuYW50IGRlcyBwYXNzYWdlcyBkdSBMb3JlbSBJcHN1bSwgZXQsIHBsdXMgcsOpY2VtbWVudCwgcGFyIHNvbiBpbmNsdXNpb24gZGFucyBkZXMgYXBwbGljYXRpb25zIGRlIG1pc2UgZW4gcGFnZSBkZSB0ZXh0ZSwgY29tbWUgQWxkdXMgUGFnZU1ha2VyLg==
Test string ";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}