import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"^(?:[A-Za-z0-9+]{4})*(?:[A-Za-z0-9+]{2}==|[A-Za-z0-9+]{3}=|[A-Za-z0-9+]{4})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
TGUgTG9yZW0gSXBzdW0gZXN0IHNpbXBsZW1lbnQgZHUgZmF1eCB0ZXh0ZSBlbXBsb3nDqSBkYW5zIGxhIGNvbXBvc2l0aW9uIGV0IGxhIG1pc2UgZW4gcGFnZSBhdmFudCBpbXByZXNzaW9uLiBMZSBMb3JlbSBJcHN1bSBlc3QgbGUgZmF1eCB0ZXh0ZSBzdGFuZGFyZCBkZSBsJ2ltcHJpbWVyaWUgZGVwdWlzIGxlcyBhbm7DqWVzIDE1MDAsIHF1YW5kIHVuIHBlaW50cmUgYW5vbnltZSBhc3NlbWJsYSBlbnNlbWJsZSBkZXMgbW9yY2VhdXggZGUgdGV4dGUgcG91ciByw6lhbGlzZXIgdW4gbGl2cmUgc3DDqWNpbWVuIGRlIHBvbGljZXMgZGUgdGV4dGUuIElsIG4nYSBwYXMgZmFpdCBxdWUgc3Vydml2cmUgY2lucSBzacOoY2xlcywgbWFpcyBzJ2VzdCBhdXNzaSBhZGFwdMOpIMOgIGxhIGJ1cmVhdXRpcXVlIGluZm9ybWF0aXF1ZSwgc2FucyBxdWUgc29uIGNvbnRlbnUgbidlbiBzb2l0IG1vZGlmacOpLiBJbCBhIMOpdMOpIHBvcHVsYXJpc8OpIGRhbnMgbGVzIGFubsOpZXMgMTk2MCBncsOiY2Ugw6AgbGEgdmVudGUgZGUgZmV1aWxsZXMgTGV0cmFzZXQgY29udGVuYW50IGRlcyBwYXNzYWdlcyBkdSBMb3JlbSBJcHN1bSwgZXQsIHBsdXMgcsOpY2VtbWVudCwgcGFyIHNvbiBpbmNsdXNpb24gZGFucyBkZXMgYXBwbGljYXRpb25zIGRlIG1pc2UgZW4gcGFnZSBkZSB0ZXh0ZSwgY29tbWUgQWxkdXMgUGFnZU1ha2VyLg==
Test string
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)