use strict;
my $str = '<?php
class Device {
protected $name;
protected $isOn = false;
function __construct($name = "Unknown Device") {
$this->name = $name;
}
function turnOn() {
$this->isOn = true;
echo "{$this->name} is turned on.<br>";
}
function turnOff() {
$this->isOn = false;
echo "{$this->name} is turned off.<br>";
}
function getStatus() {
$status = $this->isOn ? "on" : "off";
echo "{$this->name} is currently {$status}.<br>";
}
}
class Smartphone extends Device {
private $photos = 0;
function __construct($name = "Smartphone") {
parent::__construct($name);
}
function takePhoto() {
if ($this->isOn) {
$this->photos++;
echo "Photo taken! (Total: {$this->photos} photos)<br>";
} else {
echo "Please turn on the {$this->name} first!<br>";
}
}
function showPhotoCount() {
echo "Number of photos: {$this->photos}<br>";
}
}
echo "<h3>Device Class:</h3>";
$myDevice = new Device("Television");
$myDevice->turnOn();
$myDevice->getStatus();
$myDevice->turnOff();
$myDevice->getStatus();
echo "<br><h3>Smartphone Class:</h3>";
$myPhone = new Smartphone("iPhone 15");
$myPhone->getStatus();
$myPhone->takePhoto();
$myPhone->turnOn();
$myPhone->takePhoto();
$myPhone->takePhoto();
$myPhone->takePhoto();
$myPhone->showPhotoCount();
$myPhone->turnOff();
?>
';
my $regex = qr/matei 200 inheritance/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}