using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<countryCode>\+?82)?(?:[ -.]?|0?)(?<areaCode>1[01689])(?:[ -.]?)(?<firstFourDigits>\d{3,4})(?:[ -.]?)(?<lastFourDigits>\d{4})";
string input = @"+82(10)3341-6922
1063543808";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}