use strict;
my $str = '39;&39<img border=39'0'&39; &39 &39; 39test; 39; />39
39; 39%; some text in between without searched text; 39 test &; test39 39 23 39; test test 39
&&&39 ;;39 &; 39;
padding: 39%;';
my $regex = qr/(?:^&[^&;]*?)?(39)(?!(?:[^&;]*?;))|(?:(?:^|;)(?:[^&;]*?)(39))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}