$re = '/(?:^&[^&;]*?)?(39)(?!(?:[^&;]*?;))|(?:(?:^|;)(?:[^&;]*?)(39))/m';
$str = '39;&39<img border=39'0'&39; &39 &39; 39test; 39; />39
39; 39%; some text in between without searched text; 39 test &; test39 39 23 39; test test 39
&&&39 ;;39 &; 39;
padding: 39%;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);