import Foundation
let pattern = #"(?:^&[^&;]*?)?(39)(?!(?:[^&;]*?;))|(?:(?:^|;)(?:[^&;]*?)(39))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
39;&39<img border=39'0'&39; &39 &39; 39test; 39; />39
39; 39%; some text in between without searched text; 39 test &; test39 39 23 39; test test 39
&&&39 ;;39 &; 39;
padding: 39%;
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)