$re = '/^(1[0-2]|0?[1-9]):([0-5][0-9])([AaPp][Mm])(?:\|(1[0-2]|0?[1-9]):([0-5][0-9])([AaPp][Mm]))*$/m';
$str = '12:00am
12:00am|1:20PM|9:30Pm
12:00am|1:20PM
12:00am|1:20PM|9:3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);