// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r">([0-9]{10})[-<;]\s{1,2}([0-9]{4})([0-9]{5})#(\s([0-9_\?]{0,8}))?(\+\s([a-z0-9_\?]{0,5}))?(\-\s([\.,0-9_\?]{0,10})>)?").unwrap();
let string = ">1234567890< 123451234#";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}