$re = '/(?<=~).*?(?=,(?:GO:\d+~|$))/m';
$str = 'GO:0016559~peroxisome fission,
GO:0006122~mitochondrial electron transport, ubiquinol to cytochrome c,
GO:0006122~mitochondrial electron transport, ubiquinol to cytochrome c,GO:0006334~nucleosome assembly,
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);