use strict;
my $str = 'this.is.an.email@email.com
whatsinthebox@se7en
mpAdm1n@localhost
tyler.knappenberger@Gnostech.com
Damned.Proud.To.Be.Here@Gnostech.com
George.Washington@potus.gov
0123456789@numbers.num
~!#$^&*_-+|=?"@special.chars
tknappenberger@student.lasalle.edu
jane.doe45@navy.gov
2.e@s
Not an Email@whitespace.org
this%doesntWork@percentsDont.work
duplicate..periods@localhost
.emalt@w';
my $regex = qr/^[A-Za-z0-9!#$^&*|\-_+=~`?"]*([A-Za-z0-9!#$^&*|\-_+=~`?"]\.[A-Za-z0-9!#$^&*|\-_+=~`?"]+)*(\.{0,1}[A-Za-z0-9!#$^&*|\-_+=~`?"]@[A-Za-z0-9!#$^&*|\-_+=]{1,60})(\.[A-Za-z0-9!#$^&*|\-_+=~`?"]{2,60})*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}