using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?: |^)\w+(-)(?![0-9])\w+";
string input = @"Jean-Pierre bought ""blue-green-red"" product-2345 and other blue-red stuff.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}