#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{6,20}$)(?:[a-zA-Z\d]+(?:(?:\.|-|_)[a-zA-Z\d])*)+$"
Local $sString = "rubi" & @CRLF & _
"rubin1" & @CRLF & _
"_rubin" & @CRLF & _
".rubin" & @CRLF & _
"rubin_" & @CRLF & _
"rubin.1" & @CRLF & _
"rubin12" & @CRLF & _
"rubin12" & @CRLF & _
"rubin.12" & @CRLF & _
"r12fgj" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")