re = /^(?=.{6,20}$)(?:[a-zA-Z\d]+(?:(?:\.|-|_)[a-zA-Z\d])*)+$/m
str = 'rubi
rubin1
_rubin
.rubin
rubin_
rubin.1
rubin12
rubin12
rubin.12
r12fgj
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end