#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<script([^>]*)?>.*?<\/script>"
Local $sString = "<p>Hello</p><script type="text/javascript">const x = 29; console.log('Hello world');</script><p>World</p><script>alert('Hello world');</script><script src="javascript.js"></script>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)