#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(狐狸)"
Local $sString = "Sample text for testing:" & @CRLF & _
"跑叫碰" & @CRLF & _
"What Does the Fox Say? 12 狐狸怎叫 34" & @CRLF & _
"What Does the shiba inu say? 柴犬怎叫" & @CRLF & _
"怎麼叫起來像柴犬" & @CRLF & _
"怎麼叫起來像狐狸" & @CRLF & _
"狐獴(學名:Suricata suricatta)是细尾獴属的唯一物種,屬食肉目獴科,居住在南非、納米比亞及安哥拉西南部的喀拉哈里沙漠。" & @CRLF & _
"abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ" & @CRLF & _
"0123456789 +-.,!@#$%^&*();\\/|<>\"\'" & @CRLF & _
"12345 -98.7 3.141 .6180 9,000 +42" & @CRLF & _
"555.123.4567 +1-(800)-555-2468" & @CRLF & _
"foo@demo.net bar.ba@test.co.uk" & @CRLF & _
"www.demo.com http://foo.co.uk/" & @CRLF & _
"http://regexr.com/foo.html?q=bar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")