re = /(狐狸)/m
str = 'Sample text for testing:
跑叫碰
What Does the Fox Say? 12 狐狸怎叫 34
What Does the shiba inu say? 柴犬怎叫
怎麼叫起來像柴犬
怎麼叫起來像狐狸
狐獴(學名:Suricata suricatta)是细尾獴属的唯一物種,屬食肉目獴 科,居住在南非、納米比亞及安哥拉西南部的喀拉哈里沙漠。
abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ
0123456789 +-.,!@#$%^&*();\\\\/|<>\\"\\\'
12345 -98.7 3.141 .6180 9,000 +42
555.123.4567 +1-(800)-555-2468
foo@demo.net bar.ba@test.co.uk
www.demo.com http://foo.co.uk/
http://regexr.com/foo.html?q=bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end