$re = '/.*\\\\packages\\\\([^\\\\]*?)?\.(([\d]+(\.[\d]+){2,})(-[^\\\\\-\+\.]+(\.[^\\\\\-\+\.]+)*?)?(\+[^\\\\\-\+\.]+(\.[^\\\\\-\+\.]+)*?)?)\\\\.*/';
$str = '..\\..\\..\\packages\\SpecFlow.CustomPlugin.75-57-2.165d484.26546.75274.772570-test.12648.sdfg+test.sdg.1515\\lib\\net45\\Gherkin.dll';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);