$re = '~\(\s*/.*?/\w*\h*,(*SKIP)(*F)|(?|(")[^"\\\\]*(?:\\\\.[^"\\\\]*)*"|(\')[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*\')~';
$str = 'Test
a="abc";
b=\'def\';
c="That\'s the way to do it";
d=\'That\\\'s the way "to do it"\';
e=e.replace(//g, \'"\');
f=f.replace(/\'/g, \'"\');
g=g.replace(/\\\'/g, \'"\');
h=h.replace(/\\"/g, \'\\"\');
i=i.replace(/\\\\"/g, \'\\\\"\');
';
$subst = "$1XXXX$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;