import Foundation
let pattern = #"\(\s*/.*?/\w*\h*,(*SKIP)(*F)|(?|(")[^"\\]*(?:\\.[^"\\]*)*"|(')[^'\\]*(?:\\.[^'\\]*)*')"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Test
a="abc";
b='def';
c="That's the way to do it";
d='That\'s the way "to do it"';
e=e.replace(//g, '"');
f=f.replace(/'/g, '"');
g=g.replace(/\'/g, '"');
h=h.replace(/\"/g, '\"');
i=i.replace(/\\"/g, '\\"');
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1XXXX$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)