import Foundation
let pattern = #"\b(5[1-5][0-9]{2}[ -])([0-9]{4}[ -]){2}[0-9]{4}\b|\b(5[1-5][0-9]{2})([0-9]{4}){3}\b|\b222[1-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b222[1-9]([0-9]{4}){3}\b|\b22[3-9][0-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b22[3-9][0-9]([0-9]{4}){3}\b|\b2[3-6][0-9]{2}[ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b2[3-6][0-9]{2}([0-9]{4}){3}\b|\b27[01][0-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b27[01][0-9]([0-9]{4}){3}\b|\b2720[ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b2720([0-9]{4}){3}\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
MasterCard:
Requirements: MasterCard numbers either start with the numbers 51 through 55 or with the numbers 2221 through 2720. All have 16 digits.
Pattern Parts:
Starts with numbers 51 through 55:
1) \b(5[1-5][0-9]{2}[ -])([0-9]{4}[ -]){2}[0-9]{4}\b|\b(5[1-5][0-9]{2})([0-9]{4}){3}\b
Starts with numbers 2221 through 2720:
2) \b222[1-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b222[1-9]([0-9]{4}){3}\b
3) \b22[3-9][0-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b22[3-9][0-9]([0-9]{4}){3}\b
4) \b2[3-6][0-9]{2}[ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b2[3-6][0-9]{2}([0-9]{4}){3}\b
5) \b27[01][0-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b27[01][0-9]([0-9]{4}){3}\b
6) \b2720[ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b2720([0-9]{4}){3}\b
Combining 1-6 to form one pattern:
\b(5[1-5][0-9]{2}[ -])([0-9]{4}[ -]){2}[0-9]{4}\b|\b(5[1-5][0-9]{2})([0-9]{4}){3}\b|\b222[1-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b222[1-9]([0-9]{4}){3}\b|\b22[3-9][0-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b22[3-9][0-9]([0-9]{4}){3}\b|\b2[3-6][0-9]{2}[ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b2[3-6][0-9]{2}([0-9]{4}){3}\b|\b27[01][0-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b27[01][0-9]([0-9]{4}){3}\b|\b2720[ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b2720([0-9]{4}){3}\b
Test Cases:
Should fire:
16 length, no space, start with 51-55 5123123412341234
16 length, dashes, start with 51-55 5123-1234-1234-1234
16 length, spaces, start with 51-55 5123 1234 1234 1234
16 length, no space, start with 2221-2720 2221123412341234
16 length, dashes, start with 2221-2720 2221-1234-1234-1234
16 length, spaces, start with 2221-2720 2221 1234 1234 1234
16 length, no space, start with 2221-2720 2241123412341234
16 length, dashes, start with 2221-2720 2241-1234-1234-1234
16 length, spaces, start with 2221-2720 2241 1234 1234 1234
16 length, no space, start with 2221-2720 2321123412341234
16 length, dashes, start with 2221-2720 2321-1234-1234-1234
16 length, spaces, start with 2221-2720 2321 1234 1234 1234
16 length, no space, start with 2221-2720 2705123412341234
16 length, dashes, start with 2221-2720 2705-1234-1234-1234
16 length, spaces, start with 2221-2720 2705 1234 1234 1234
16 length, no space, start with 2221-2720 2720123412341234
16 length, dashes, start with 2221-2720 2720-1234-1234-1234
16 length, spaces, start with 2221-2720 2720 1234 1234 1234
Should not fire:
16 length, no space, not start with 51-55 5623123412341234
16 length, dashes, not start with 51-55 5623-1234-1234-1234
16 length, spaces, not start with 51-55 5623 1234 1234 1234
16 length, no space, not start with 2221-2720 2220123412341234
16 length, dashes, not start with 2221-2720 2220-1234-1234-1234
16 length, spaces, not start with 2221-2720 2220 1234 1234 1234
Non 16 length, matches 51 pattern start 5123-1234-1234-123
Non 16 length, matches 2221 pattern start 2221-1234-1234-123
Malformed, matches 51 pattern start 51-2312-34-1234-1234
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)