re = /(?<!\.)(?:[0-9]+(?:\.[0-9]+){3})(?!\.)/m
str = '1.1.1.1
1.1.1.1.
1.1.1.1.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end