using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<url>\s*<loc>[^<]+login.+?</url>\s*";
string substitution = @"";
string input = @"<url>
<loc>http://review-pref.ru/literatura/49/131/</loc>
<changefreq>monthly</changefreq>
<priority>0.3</priority>
</url>
<url>
<loc>http://review-pref.ru/folklor/4/178/4/javascript/login</loc>
<changefreq>monthly</changefreq>
<priority>0.3</priority>
</url>
<url>
<loc>http://review-pref.ru/literatura/56/65/login/javascript/login/login/</loc>
<changefreq>monthly</changefreq>
<priority>0.3</priority>
</url>
<url>
<loc>http://review-pref.ru/folklor/4/164/</loc>
<changefreq>monthly</changefreq>
<priority>0.3</priority>
</url>
";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}