import Foundation
let pattern = #"<url>\s*<loc>[^<]+login.+?</url>\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<url>
<loc>http://review-pref.ru/literatura/49/131/</loc>
<changefreq>monthly</changefreq>
<priority>0.3</priority>
</url>
<url>
<loc>http://review-pref.ru/folklor/4/178/4/javascript/login</loc>
<changefreq>monthly</changefreq>
<priority>0.3</priority>
</url>
<url>
<loc>http://review-pref.ru/literatura/56/65/login/javascript/login/login/</loc>
<changefreq>monthly</changefreq>
<priority>0.3</priority>
</url>
<url>
<loc>http://review-pref.ru/folklor/4/164/</loc>
<changefreq>monthly</changefreq>
<priority>0.3</priority>
</url>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)