$re = '/\/var\/log\/containers\/container_name_\w{27}.log$/m';
$str = '/var/log/containers/container_name_fdsdjkfasdfads5f4s6dfsda65f.log';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);