using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^.*\n|.*$)";
string input = @"[abilities]
UnknownDescTech0 = このアビリティの効果は不明。
UnknownDescFun0 = 説明なし。
UnknownName = ???のアビリティ。
OneHitDeathName = ワンパンヒーローのバッジ
OneHitDeathDesc0 = 一発で死にます。上級者向け!
SuckInOrbsName = 磁石のバッジ
SuckInOrbsFun0 = アイテムに手が届かない? これでもう安心。
SuckInOrbsTech0 = 自動で近くのアイテムを引き寄せます!
[abilities_test]
UnknownName = ??? Ability
UnknownDescFun0 = No description.
UnknownDescTech0 = This ability does not seem to have any purpose.
OneHitDeathName = 1-Hit Hero Badge
OneHitDeathDesc0 = You die in one hit. Only for the brave!
SuckInOrbsName = Item Magnet Badge
SuckInOrbsFun0 = Item just out of reach? No longer a problem!
SuckInOrbsTech0 = Automatically attract nearby collectibles!";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}