#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=")[^"]+?(?="(?:\s*?,|\s*?$))|(?<=(?:^|,)\s*?)(?:[^,"\s][^,"]*[^,"\s])|(?:[^,"\s])(?![^"]*?"(?:\s*?,|\s*?$))(?=\s*?(?:,|$))"
Local $sString = "it, finds, values, in, comma, separated, lists" & @CRLF & _
"(it also matches new lines and any whitespace, hence the end-of-line highlight) " & @CRLF & _
"it, "handles double quotes"" & @CRLF & _
"it, "handles, double, quotes, with, commas, in, them"" & @CRLF & _
" it, ignores, trailing whitespaces " & @CRLF & _
"" unless it's in quotes "" & @CRLF & _
",,,,,and,,,,,handles-??-weird.stuff,,,,,,?????" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")