$re = '/(?<=")[^"]+?(?="(?:\s*?,|\s*?$))|(?<=(?:^|,)\s*?)(?:[^,"\s][^,"]*[^,"\s])|(?:[^,"\s])(?![^"]*?"(?:\s*?,|\s*?$))(?=\s*?(?:,|$))/m';
$str = 'it, finds, values, in, comma, separated, lists
(it also matches new lines and any whitespace, hence the end-of-line highlight)
it, "handles double quotes"
it, "handles, double, quotes, with, commas, in, them"
it, ignores, trailing whitespaces
" unless it\'s in quotes "
,,,,,and,,,,,handles-??-weird.stuff,,,,,,?????
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);