using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![0.]+$)(?:[1-9]\d*|0)(?:\.\d{1,2})?$";
string input = @"0.01
1.1
1.02
120.01
0.0
0.00
0023
0100
.01
.12
00.4
001.02
0000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}