$re = '~\\\\index(\{((?:[^{}]+|(?1))+)\})~m';
$str = 'Sentence \\index{Palenque} with two LaTeX index entries \\index{Yaxchilan!Itzamnaah B\'ahlam@\\textit{Itzamnaah B\'ahlam}!warfare} in it.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);