package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)([=])(.*)`)
var str = `7K_1=one9,o1;;1;8o^&%$#!@#y
K_2=val2
KEY3=val3
KEY4=val4
KEY=valueone
KEY2=value two spaces
KEY3=%specialChars&[*}*&()';
KEY_4=val4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}