const regex = new RegExp('(.*)([=])(.*)', 'gm')
const str = `7K_1=one9,o1;;1;8o^&%\$#!@#y
K_2=val2
KEY3=val3
KEY4=val4
KEY=valueone
KEY2=value two spaces
KEY3=%specialChars&[*}*&()';
KEY_4=val4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}