const regex = /^(?:(?:(?<three>\d+),)?(?<two>\d+),)?(?<one>\d+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:(?<three>\\d+),)?(?<two>\\d+),)?(?<one>\\d+)$', 'gm')
const str = `1,4,34
5,15
22
1,2,3
11,12
11,12,13
1,2
1
,1,2,3
,1,2
,1
,
1234
1,234
1234,123
1,2
111,222
111,2,4444
11,22
12345,12345,12345
12345,12345,12345,12345
,,
1,
1,2,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}